FreeBSD : FreeBSD -- Multiple libarchive vulnerabilities (1a71a972-8ee7-11e6-a590-14dae9d210b8)

High Nessus Plugin ID 93942


The remote FreeBSD host is missing one or more security-related updates.


Flaws in libarchive's handling of symlinks and hard links allow overwriting files outside the extraction directory, or permission changes to a directory outside the extraction directory. Impact : An attacker who can control freebsd-update's or portsnap's input to tar(1) can change file content or permissions on files outside of the update tool's working sandbox.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 93942

File Name: freebsd_pkg_1a71a9728ee711e6a59014dae9d210b8.nasl

Version: $Revision: 2.2 $

Type: local

Published: 2016/10/11

Modified: 2017/07/05

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:FreeBSD, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info, Settings/ParanoidReport

Patch Publication Date: 2016/10/10

Vulnerability Publication Date: 2016/10/05

Reference Information

FreeBSD: SA-16:31.libarchive