FreeBSD : libraries -- multiple vulnerabilities (1cf65085-a760-41d2-9251-943e1af62eb8)

High Nessus Plugin ID 93933


The remote FreeBSD host is missing one or more security-related updates.


Matthieu Herrb reports :

Tobias Stoeckmann from the OpenBSD project has discovered a number of issues in the way various X client libraries handle the responses they receive from servers, and has worked with X.Org's security team to analyze, confirm, and fix these issues. These issue come in addition to the ones discovered by Ilja van Sprundel in 2013.

Most of these issues stem from the client libraries trusting the server to send correct protocol data, and not verifying that the values will not overflow or cause other damage. Most of the time X clients and servers are run by the same user, with the server more privileged than the clients, so this is not a problem, but there are scenarios in which a privileged client can be connected to an unprivileged server, for instance, connecting a setuid X client (such as a screen lock program) to a virtual X server (such as Xvfb or Xephyr) which the user has modified to return invalid data, potentially allowing the user to escalate their privileges.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 93933

File Name: freebsd_pkg_1cf65085a76041d29251943e1af62eb8.nasl

Version: $Revision: 2.3 $

Type: local

Published: 2016/10/10

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libX11, p-cpe:/a:freebsd:freebsd:libXfixes, p-cpe:/a:freebsd:freebsd:libXi, p-cpe:/a:freebsd:freebsd:libXrandr, p-cpe:/a:freebsd:freebsd:libXrender, p-cpe:/a:freebsd:freebsd:libXtst, p-cpe:/a:freebsd:freebsd:libXv, p-cpe:/a:freebsd:freebsd:libXvMC, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/10/07

Vulnerability Publication Date: 2016/10/04

Reference Information

CVE: CVE-2016-5407