Cisco IOS XE Multicast Routing Multiple DoS (cisco-sa-20160928-msdp)

high Nessus Plugin ID 93898

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

According to its self-reported version number and configuration, the remote Cisco IOS XE device is affected by multiple denial of service vulnerabilities :

- A denial of service vulnerability exists due to improper validation of packets encapsulated in a PIM register message. An unauthenticated, remote attacker can exploit this, by sending an IPv6 PIM register packet to a PIM rendezvous point (RP), to cause the device to restart.
(CVE-2016-6382)

- A denial of service vulnerability exists in the IPv4 Multicast Source Discovery Protocol (MSDP) implementation due to improper validation of Source-Active (SA) messages received from a configured MSDP peer. An unauthenticated, remote attacker can exploit this to cause the device to restart.
(CVE-2016-6392)

Solution

Upgrade to the relevant fixed version referenced in Cisco security advisory cisco-sa-20160928-msdp.

See Also

http://www.nessus.org/u?72b1793a

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCud36767

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCuy16399

Plugin Details

Severity: High

ID: 93898

File Name: cisco-sa-20160928-msdp-iosxe.nasl

Version: 1.10

Type: local

Family: CISCO

Published: 10/7/2016

Updated: 11/14/2019

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:cisco:ios_xe

Required KB Items: Host/Cisco/IOS-XE/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 9/28/2016

Vulnerability Publication Date: 9/28/2016

Reference Information

CVE: CVE-2016-6382, CVE-2016-6392

BID: 93211