MariaDB 10.1.x < 10.1.12 Multiple Vulnerabilities

medium Nessus Plugin ID 93829
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is 10.1.x prior to 10.1.12. It is, therefore, affected by multiple vulnerabilities :

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to impact integrity and availability. (CVE-2016-0640)

- An unspecified flaw exists in the MyISAM subcomponent that allows an authenticated, remote attacker to disclose sensitive information or cause a denial of service condition. (CVE-2016-0641)

- An unspecified flaw exists in the DDL subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0644)

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0646)

- An unspecified flaw exists in the PS subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0649)

- An unspecified flaw exists in the Replication subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-0650)

- An unspecified flaw exists in the InnoDB subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0668)

- A denial of service vulnerability exists in the SELECT_LEX::update_used_tables() function in sql_lex.cc due to improper handling of semi-join conditions on used table updates. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the JOIN::choose_subquery_plan() function in opt_subselect.cc due to improper handling of nested IN clauses that contain SQ. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the select_create::prepare() function in sql_insert.cc due to improper handling of stored procedures in new tables.
An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in item_cmpfunc.cc due to improper handling of EXECUTE statements. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the subselect_hash_sj_engine::exec() function in item_subselect.cc due to improper handling of UNION ALL statements. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the Rows_log_event::process_triggers() function in log_event.cc due to improper handling of the update statement for minimal row image sets. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in sql_select.cc due to improper creation of keys in temporary tables. An authenticated, remote attacker can exploit this to crash the database.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 10.1.12 or later.

See Also

http://www.nessus.org/u?2747217e

https://mariadb.com/kb/en/library/mariadb-10112-changelog/

https://mariadb.com/kb/en/mariadb/mariadb-10112-release-notes/

Plugin Details

Severity: Medium

ID: 93829

File Name: mariadb_10_1_12.nasl

Version: 1.9

Type: remote

Family: Databases

Published: 10/3/2016

Updated: 11/14/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2016-0641

VPR

Risk Factor: Medium

Score: 4.2

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: AV:N/AC:M/Au:S/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.1

Temporal Score: 4.5

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/11/2016

Vulnerability Publication Date: 11/17/2014

Reference Information

CVE: CVE-2016-0640, CVE-2016-0641, CVE-2016-0644, CVE-2016-0646, CVE-2016-0649, CVE-2016-0650, CVE-2016-0668