MariaDB 10.0.x < 10.0.24 Multiple Vulnerabilities

Medium Nessus Plugin ID 93828

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is 10.0.x prior to 10.0.24. It is, therefore, affected by multiple vulnerabilities :

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to impact integrity and availability. (CVE-2016-0640)

- An unspecified flaw exists in the MyISAM subcomponent that allows an authenticated, remote attacker to disclose sensitive information or cause a denial of service condition. (CVE-2016-0641)

- An unspecified flaw exists in the DDL subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0644)

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0646)

- An unspecified flaw exists in the PS subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0649)

- An unspecified flaw exists in the Replication subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-0650)

- An unspecified flaw exists in the InnoDB subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0668)

- A denial of service vulnerability exists in the SELECT_LEX::update_used_tables() function in sql_lex.cc due to improper handling of semi-join conditions on used table updates. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the JOIN::choose_subquery_plan() function in opt_subselect.cc due to improper handling of nested IN clauses that contain SQ. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the select_create::prepare() function in sql_insert.cc due to improper handling of stored procedures in new tables.
An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in sql_select.cc due to improper creation of keys in temporary tables. An authenticated, remote attacker can exploit this to crash the database.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 10.0.24 or later.

See Also

https://mariadb.org/mariadb-10-0-24-now-available/

https://mariadb.com/kb/en/library/mariadb-10024-changelog/

https://mariadb.com/kb/en/mariadb/mariadb-10024-release-notes/

Plugin Details

Severity: Medium

ID: 93828

File Name: mariadb_10_0_24.nasl

Version: 1.8

Type: remote

Family: Databases

Published: 2016/10/03

Updated: 2019/01/02

Dependencies: 91823, 10719

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/11

Vulnerability Publication Date: 2014/11/17

Reference Information

CVE: CVE-2016-0640, CVE-2016-0641, CVE-2016-0644, CVE-2016-0646, CVE-2016-0649, CVE-2016-0650, CVE-2016-0668