MariaDB 5.5.x < 5.5.49 Multiple Vulnerabilities

low Nessus Plugin ID 93616
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is 5.5.x prior to 5.5.49. It is, therefore, affected by the following vulnerabilities :

- An unspecified flaw exists in the DML component that allows an authenticated, remote attacker to disclose sensitive information. (CVE-2016-0643)

- An unspecified flaw exists in the FTS component that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0647)

- An unspecified flaw exists in the PS component that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0648)

- An unspecified flaw exists in the Security: Privileges component that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0666)

- An unspecified flaw exists in the Encryption component that allows an unauthenticated, remote attacker to disclose sensitive information. (CVE-2016-3452)

- An unspecified flaw exists in the Connection component that allows an unauthenticated, remote attacker to disclose sensitive information. (CVE-2016-5444)

- A denial of service vulnerability exists in the my_decimal_precision_to_length_no_truncation() function within file item_cmpfunc.cc when handling SELECT CASE statements. An authenticated, remote attacker can exploit this to crash the database.

- A buffer overflow condition exists in the audit_plugin_so_init() function within file plugin/server_audit/server_audit.c due to improper validation of user-supplied input. An authenticated, remote attacker can exploit this to cause a denial of service condition or the execution of arbitrary code.

Solution

Upgrade to MariaDB version 5.5.49 or later.

See Also

https://mariadb.com/kb/en/mariadb/mariadb-5549-release-notes/

https://mariadb.com/kb/en/library/mariadb-5549-changelog/

Plugin Details

Severity: Low

ID: 93616

File Name: mariadb_5_5_49.nasl

Version: 1.9

Type: remote

Family: Databases

Published: 9/21/2016

Updated: 11/14/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2016-5444

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/22/2016

Vulnerability Publication Date: 4/19/2016

Reference Information

CVE: CVE-2016-0643, CVE-2016-0647, CVE-2016-0648, CVE-2016-0666, CVE-2016-3452, CVE-2016-5444

BID: 86457, 86486, 86495, 86509, 91987, 91999