MariaDB 10.1.x < 10.1.17 Multiple Vulnerabilities

critical Nessus Plugin ID 93610
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is 10.1.x prior to 10.1.17. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in the check_log_path() function within file sql/sys_vars.cc due to inadequate restrictions on the ability to write to the my.cnf configuration file and allowing the loading of configuration files from path locations not used by current versions. An authenticated, remote attacker can exploit this issue by using specially crafted queries that utilize logging functionality to create new files or append custom content to existing files. This allows the attacker to gain root privileges by inserting a custom .cnf file with a 'malloc_lib=' directive pointing to specially crafted mysql_hookandroot_lib.so file and thereby cause MySQL to load a malicious library the next time it is started. (CVE-2016-6662)

- A NULL pointer dereference flaw exists in the innobase_need_rebuild() function when handling renamed columns that allows an authenticated, remote attacker to crash the database, resulting in a denial of service.

- A denial of service vulnerability exists in the ha_myisam::enable_indexes() function within file storage/myisam/ha_myisam.cc when handling ALTER TABLE statements. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the Item_sum_std::val_real() function within file sql/item_sum.cc when handling SUM statements. An authenticated, remote attacker exploit this to crash the database.

- A denial of service vulnerability exists within file sql/item_subselect.cc when handling specially crafted queries for non-existent functions. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the Item_subselect::is_expensive() function within file sql/item_subselect.cc due to improper handling of optimization procedures. An authenticated, remote attacker can exploit this to crash the database.

- A denial of service vulnerability exists in the st_select_lex_unit::cleanup() function within file sql/sql_union.cc when handling UNION queries during JOIN cleanup. An authenticated, remote attacker can exploit this to crash the database.

Solution

Upgrade to MariaDB version 10.1.17 or later.

See Also

http://www.nessus.org/u?074893a6

https://mariadb.com/kb/en/library/mariadb-10117-changelog/

https://mariadb.com/kb/en/library/mariadb-10117-release-notes/

https://jira.mariadb.org/browse/MDEV-9304

https://jira.mariadb.org/browse/MDEV-10045

https://jira.mariadb.org/browse/MDEV-10419

https://jira.mariadb.org/browse/MDEV-10465

http://www.nessus.org/u?fbd97f45

Plugin Details

Severity: Critical

ID: 93610

File Name: mariadb_10_1_17.nasl

Version: 1.11

Type: remote

Family: Databases

Published: 9/20/2016

Updated: 11/14/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2016-6662

VPR

Risk Factor: Critical

Score: 9.2

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/30/2015

Vulnerability Publication Date: 12/18/2015

Reference Information

CVE: CVE-2016-6662

BID: 92912

EDB-ID: 40360