openSUSE Security Update : perl (openSUSE-2016-1086)

High Nessus Plugin ID 93583


The remote openSUSE host is missing a security update.


This update for Perl fixes the following issues :

- CVE-2016-6185: Xsloader looking at a '(eval)' directory.

- CVE-2016-1238: Searching current directory for optional modules. (bsc#987887)

- CVE-2015-8853: Regular expression engine hanging on bad utf8. (bsc)

- CVE-2016-2381: Environment dup handling bug.

- 'Insecure dependency in require' error in taint mode.

- Memory leak in 'use utf8' handling. (bsc#928292)

- Missing lock prototype to the debugger. (bsc#932894)

This update was imported from the SUSE:SLE-12:Update update project.


Update the affected perl packages.

See Also

Plugin Details

Severity: High

ID: 93583

File Name: openSUSE-2016-1086.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2016/09/19

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C


Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl, p-cpe:/a:novell:opensuse:perl-32bit, p-cpe:/a:novell:opensuse:perl-base, p-cpe:/a:novell:opensuse:perl-base-32bit, p-cpe:/a:novell:opensuse:perl-base-debuginfo, p-cpe:/a:novell:opensuse:perl-base-debuginfo-32bit, p-cpe:/a:novell:opensuse:perl-debuginfo, p-cpe:/a:novell:opensuse:perl-debuginfo-32bit, p-cpe:/a:novell:opensuse:perl-debugsource, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/09/15

Reference Information

CVE: CVE-2015-8853, CVE-2016-1238, CVE-2016-2381, CVE-2016-6185