SUSE SLED12 Security Update : flash-player (SUSE-SU-2016:2312-1)

Critical Nessus Plugin ID 93558

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for flash-player fixes the following security issues (APSB16-29, boo#998589) :

- integer overflow vulnerability that could lead to code execution (CVE-2016-4287).

- use-after-free vulnerabilities that could lead to code execution (CVE-2016-4272, CVE-2016-4279, CVE-2016-6921, CVE-2016-6923, CVE-2016-6925, CVE-2016-6926, CVE-2016-6927, CVE-2016-6929, CVE-2016-6930, CVE-2016-6931, CVE-2016-6932)

- security bypass vulnerabilities that could lead to information disclosure (CVE-2016-4271, CVE-2016-4277, CVE-2016-4278)

- memory corruption vulnerabilities that could lead to code execution (CVE-2016-4182, CVE-2016-4237, CVE-2016-4238, CVE-2016-4274, CVE-2016-4275, CVE-2016-4276, CVE-2016-4280, CVE-2016-4281, CVE-2016-4282, CVE-2016-4283, CVE-2016-4284, CVE-2016-4285, CVE-2016-6922, CVE-2016-6924)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Workstation Extension 12-SP1:zypper in -t patch SUSE-SLE-WE-12-SP1-2016-1353=1

SUSE Linux Enterprise Desktop 12-SP1:zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2016-1353=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=998589

https://www.suse.com/security/cve/CVE-2016-4182/

https://www.suse.com/security/cve/CVE-2016-4237/

https://www.suse.com/security/cve/CVE-2016-4238/

https://www.suse.com/security/cve/CVE-2016-4271/

https://www.suse.com/security/cve/CVE-2016-4272/

https://www.suse.com/security/cve/CVE-2016-4274/

https://www.suse.com/security/cve/CVE-2016-4275/

https://www.suse.com/security/cve/CVE-2016-4276/

https://www.suse.com/security/cve/CVE-2016-4277/

https://www.suse.com/security/cve/CVE-2016-4278/

https://www.suse.com/security/cve/CVE-2016-4279/

https://www.suse.com/security/cve/CVE-2016-4280/

https://www.suse.com/security/cve/CVE-2016-4281/

https://www.suse.com/security/cve/CVE-2016-4282/

https://www.suse.com/security/cve/CVE-2016-4283/

https://www.suse.com/security/cve/CVE-2016-4284/

https://www.suse.com/security/cve/CVE-2016-4285/

https://www.suse.com/security/cve/CVE-2016-4287/

https://www.suse.com/security/cve/CVE-2016-6921/

https://www.suse.com/security/cve/CVE-2016-6922/

https://www.suse.com/security/cve/CVE-2016-6923/

https://www.suse.com/security/cve/CVE-2016-6924/

https://www.suse.com/security/cve/CVE-2016-6925/

https://www.suse.com/security/cve/CVE-2016-6926/

https://www.suse.com/security/cve/CVE-2016-6927/

https://www.suse.com/security/cve/CVE-2016-6929/

https://www.suse.com/security/cve/CVE-2016-6930/

https://www.suse.com/security/cve/CVE-2016-6931/

https://www.suse.com/security/cve/CVE-2016-6932/

http://www.nessus.org/u?37a1e318

Plugin Details

Severity: Critical

ID: 93558

File Name: suse_SU-2016-2312-1.nasl

Version: 2.9

Type: local

Agent: unix

Published: 2016/09/16

Updated: 2018/11/29

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:flash-player, p-cpe:/a:novell:suse_linux:flash-player-gnome, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/09/15

Reference Information

CVE: CVE-2016-4182, CVE-2016-4237, CVE-2016-4238, CVE-2016-4271, CVE-2016-4272, CVE-2016-4274, CVE-2016-4275, CVE-2016-4276, CVE-2016-4277, CVE-2016-4278, CVE-2016-4279, CVE-2016-4280, CVE-2016-4281, CVE-2016-4282, CVE-2016-4283, CVE-2016-4284, CVE-2016-4285, CVE-2016-4287, CVE-2016-6921, CVE-2016-6922, CVE-2016-6923, CVE-2016-6924, CVE-2016-6925, CVE-2016-6926, CVE-2016-6927, CVE-2016-6929, CVE-2016-6930, CVE-2016-6931, CVE-2016-6932