FreeBSD : dropbear -- multiple vulnerabilities (bc19dcca-7b13-11e6-b99e-589cfc0654e1)

Critical Nessus Plugin ID 93552


The remote FreeBSD host is missing a security-related update.


Matt Johnston reports :

If specific usernames including '%' symbols can be created on a system (validated by getpwnam()) then an attacker could run arbitrary code as root when connecting to Dropbear server.

A dbclient user who can control username or host arguments could potentially run arbitrary code as the dbclient user. This could be a problem if scripts or webpages pass untrusted input to the dbclient program.

dropbearconvert import of OpenSSH keys could run arbitrary code as the local dropbearconvert user when parsing malicious key files.

dbclient could run arbitrary code as the local dbclient user if particular -m or -c arguments are provided. This could be an issue where dbclient is used in scripts.

dbclient or dropbear server could expose process memory to the running user if compiled with DEBUG_TRACE and running with -v


Update the affected package.

See Also

Plugin Details

Severity: Critical

ID: 93552

File Name: freebsd_pkg_bc19dcca7b1311e6b99e589cfc0654e1.nasl

Version: $Revision: 2.2 $

Type: local

Published: 2016/09/16

Modified: 2017/03/06

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:dropbear, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/09/15

Vulnerability Publication Date: 2016/07/12

Reference Information

CVE: CVE-2016-7406, CVE-2016-7407, CVE-2016-7408, CVE-2016-7409