SUSE SLED12 / SLES12 Security Update : gd (SUSE-SU-2016:2303-1)

Medium Nessus Plugin ID 93506

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for gd fixes the following issues :

- CVE-2016-6214: Buffer over-read issue when parsing crafted TGA file [bsc#991436]

- CVE-2016-6132: read out-of-bands was found in the parsing of TGA files using libgd [bsc#987577]

- CVE-2016-6128: Invalid color index not properly handled [bsc#991710]

- CVE-2016-6207: Integer overflow error within
_gdContributionsAlloc() [bsc#991622]

- CVE-2016-6161: global out of bounds read when encoding gif from malformed input withgd2togif [bsc#988032]

- CVE-2016-5116: avoid stack overflow (read) with large names [bsc#982176]

- CVE-2016-6905: Out-of-bounds read in function read_image_tga in gd_tga.c [bsc#995034]

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Workstation Extension 12-SP1:zypper in -t patch SUSE-SLE-WE-12-SP1-2016-1347=1

SUSE Linux Enterprise Software Development Kit 12-SP1:zypper in -t patch SUSE-SLE-SDK-12-SP1-2016-1347=1

SUSE Linux Enterprise Server 12-SP1:zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-1347=1

SUSE Linux Enterprise Desktop 12-SP1:zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2016-1347=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=982176

https://bugzilla.suse.com/show_bug.cgi?id=987577

https://bugzilla.suse.com/show_bug.cgi?id=988032

https://bugzilla.suse.com/show_bug.cgi?id=991436

https://bugzilla.suse.com/show_bug.cgi?id=991622

https://bugzilla.suse.com/show_bug.cgi?id=991710

https://bugzilla.suse.com/show_bug.cgi?id=995034

https://www.suse.com/security/cve/CVE-2016-5116/

https://www.suse.com/security/cve/CVE-2016-6128/

https://www.suse.com/security/cve/CVE-2016-6132/

https://www.suse.com/security/cve/CVE-2016-6161/

https://www.suse.com/security/cve/CVE-2016-6207/

https://www.suse.com/security/cve/CVE-2016-6214/

https://www.suse.com/security/cve/CVE-2016-6905/

http://www.nessus.org/u?9d211461

Plugin Details

Severity: Medium

ID: 93506

File Name: suse_SU-2016-2303-1.nasl

Version: 2.8

Type: local

Agent: unix

Published: 2016/09/15

Updated: 2019/09/11

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:gd, p-cpe:/a:novell:suse_linux:gd-debuginfo, p-cpe:/a:novell:suse_linux:gd-debugsource, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/09/14

Vulnerability Publication Date: 2016/08/07

Reference Information

CVE: CVE-2016-5116, CVE-2016-6128, CVE-2016-6132, CVE-2016-6161, CVE-2016-6207, CVE-2016-6214, CVE-2016-6905