SUSE SLES11 Security Update : sqlite3 (SUSE-SU-2016:2021-1)

Medium Nessus Plugin ID 93285


The remote SUSE host is missing one or more security updates.


This update for sqlite3 fixes the following issues: The following security issue was fixed :

- CVE-2016-6153: Fixed a tempdir selection vulnerability (bsc#987394)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Studio Onsite 1.3:zypper in -t patch slestso13-sqlite3-12687=1

SUSE Linux Enterprise Software Development Kit 11-SP4:zypper in -t patch sdksp4-sqlite3-12687=1

SUSE Linux Enterprise Server 11-SP4:zypper in -t patch slessp4-sqlite3-12687=1

SUSE Linux Enterprise Debuginfo 11-SP4:zypper in -t patch dbgsp4-sqlite3-12687=1

To bring your system up-to-date, use 'zypper patch'.

See Also

Plugin Details

Severity: Medium

ID: 93285

File Name: suse_SU-2016-2021-1.nasl

Version: $Revision: 2.4 $

Type: local

Agent: unix

Published: 2016/09/02

Modified: 2016/12/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 5.9

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libsqlite3, p-cpe:/a:novell:suse_linux:libsqlite3-0, p-cpe:/a:novell:suse_linux:sqlite3, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/08/10

Reference Information

CVE: CVE-2016-6153

OSVDB: 140838