openSUSE Security Update : hawk2 (openSUSE-2016-971)

High Nessus Plugin ID 92977


The remote openSUSE host is missing a security update.


This update for hawk2 fixes one security issue and one bug.

The following security change is included :

- To prevent Clickjacking attacks, set Content-Security-Policy to frame-ancestors 'self' (bsc#984619)

The following non-security issue was fixed :

- In the Wizards UI, prevent text display issues due to internationalization with certain strings (bsc#987696)

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Update the affected hawk2 packages.

See Also

Plugin Details

Severity: High

ID: 92977

File Name: openSUSE-2016-971.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2016/08/16

Modified: 2016/08/16

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:hawk2, p-cpe:/a:novell:opensuse:hawk2-debuginfo, p-cpe:/a:novell:opensuse:hawk2-debugsource, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/08/11