FreeBSD : FreeBSD -- shell injection vulnerability in patch(1) (0d090952-600a-11e6-a6c3-14dae9d210b8)

High Nessus Plugin ID 92892


The remote FreeBSD host is missing a security-related update.


Due to insufficient sanitization of the input patch stream, it is possible for a patch file to cause patch(1) to pass certain ed(1) scripts to the ed(1) editor, which would run commands. Impact : This issue could be exploited to execute arbitrary commands as the user invoking patch(1) against a specially crafted patch file, which could be leveraged to obtain elevated privileges.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 92892

File Name: freebsd_pkg_0d090952600a11e6a6c314dae9d210b8.nasl

Version: 2.4

Type: local

Published: 2016/08/12

Modified: 2018/03/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C


Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:FreeBSD, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info, Settings/ParanoidReport

Patch Publication Date: 2016/08/11

Vulnerability Publication Date: 2015/08/05

Reference Information

CVE: CVE-2015-1418

FreeBSD: SA-15:18.bsdpatch