Debian DLA-560-2 : cacti regression update

Medium Nessus Plugin ID 92547

Synopsis

The remote Debian host is missing a security update.

Description

Three security issues have been found in cacti :

CVE-2016-2313

auth_login.php allows remote authenticated users who use web authentication to bypass intended access restrictions by logging in as a user not in the cacti database.

CVE-2016-3172

A SQL injection vulnerability in tree.php allows remote authenticated users to execute arbitrary SQL commands via the parent_id parameter in an item_edit action.

CVE-2016-3659

A SQL injection vulnerability in graph_view.php allows remote authenticated users to execute arbitrary SQL commands via the host_group_data parameter.

The fix for CVE-2016-2313 did not take into account guest users. This update fixes it.

For Debian 7 'Wheezy', these problems have been fixed in version 0.8.8a+dfsg-5+deb7u10.

We recommend that you upgrade your cacti packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected cacti package.

See Also

https://lists.debian.org/debian-lts-announce/2016/09/msg00000.html

https://packages.debian.org/source/wheezy/cacti

Plugin Details

Severity: Medium

ID: 92547

File Name: debian_DLA-560.nasl

Version: 2.7

Type: local

Agent: unix

Published: 2016/07/26

Updated: 2018/07/09

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:cacti, cpe:/o:debian:debian_linux:7.0

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/09/01

Reference Information

CVE: CVE-2016-2313, CVE-2016-3172, CVE-2016-3659