GLSA-201606-17 : hostapd and wpa_supplicant: Multiple vulnerabilities

Medium Nessus Plugin ID 91862


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201606-17 (hostapd and wpa_supplicant: Multiple vulnerabilities)

Multiple vulnerabilities exist in both hostapd and wpa_supplicant.
Please review the CVE identifiers for more information.
Impact :

Remote attackers could execute arbitrary code with the privileges of the process or cause Denial of Service.
Workaround :

There is no known workaround at this time.


All hostapd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-wireless/hostapd-2.5' All wpa_supplicant users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-wireless/wpa_supplicant-2.5-r1'

See Also

Plugin Details

Severity: Medium

ID: 91862

File Name: gentoo_GLSA-201606-17.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2016/06/28

Modified: 2016/06/28

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:hostapd, p-cpe:/a:gentoo:linux:wpa_supplicant, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/06/27

Reference Information

CVE: CVE-2014-3686, CVE-2015-1863, CVE-2015-4141, CVE-2015-4142, CVE-2015-4143, CVE-2015-4144, CVE-2015-4145, CVE-2015-4146

GLSA: 201606-17