CVE-2015-4141

MEDIUM

Description

The WPS UPnP function in hostapd, when using WPS AP, and wpa_supplicant, when using WPS external registrar (ER), 0.7.0 through 2.4 allows remote attackers to cause a denial of service (crash) via a negative chunk length, which triggers an out-of-bounds read or heap-based buffer overflow.

References

http://lists.opensuse.org/opensuse-updates/2015-06/msg00019.html

http://w1.fi/security/2015-2/wps-upnp-http-chunked-transfer-encoding.txt

http://www.debian.org/security/2015/dsa-3397

http://www.openwall.com/lists/oss-security/2015/05/09/4

http://www.openwall.com/lists/oss-security/2015/05/31/6

http://www.ubuntu.com/usn/USN-2650-1

https://security.gentoo.org/glsa/201606-17

Details

Source: MITRE

Published: 2015-06-15

Updated: 2018-10-30

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
143627SUSE SLED15 / SLES15 Security Update : wpa_supplicant (SUSE-SU-2020:3380-1) (KRACK)NessusSuSE Local Security Checks
medium
143321openSUSE Security Update : wpa_supplicant (openSUSE-2020-2053) (KRACK)NessusSuSE Local Security Checks
medium
143304openSUSE Security Update : wpa_supplicant (openSUSE-2020-2059) (KRACK)NessusSuSE Local Security Checks
medium
104237openSUSE Security Update : hostapd (openSUSE-2017-1201) (KRACK)NessusSuSE Local Security Checks
medium
93700openSUSE Security Update : wpa_supplicant (openSUSE-2016-1104)NessusSuSE Local Security Checks
medium
93507SUSE SLED12 / SLES12 Security Update : wpa_supplicant (SUSE-SU-2016:2305-1)NessusSuSE Local Security Checks
medium
91862GLSA-201606-17 : hostapd and wpa_supplicant: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
87279SUSE SLED11 / SLES11 Security Update : wpa_supplicant (SUSE-SU-2015:2221-1)NessusSuSE Local Security Checks
medium
86833Debian DSA-3397-1 : wpa - security updateNessusDebian Local Security Checks
medium
84230Ubuntu 12.04 LTS / 14.04 LTS / 14.10 / 15.04 : wpa, wpasupplicant vulnerabilities (USN-2650-1)NessusUbuntu Local Security Checks
medium
84183openSUSE Security Update : wpa-supplicant (openSUSE-2015-411)NessusSuSE Local Security Checks
medium
83964FreeBSD : hostapd and wpa_supplicant -- multiple vulnerabilities (bbc0db92-084c-11e5-bb90-002590263bf5)NessusFreeBSD Local Security Checks
medium