VMware vCenter Server 5.0.x < 5.0u3g / 5.1.x < 5.1u3d / 5.5.x < 5.5u2d Reflected XSS (VMSA-2016-0009)

medium Nessus Plugin ID 91713


A virtualization management application installed on the remote host is affected by a reflected cross-site scripting vulnerability.


The version of VMware vCenter Server installed on the remote host is 5.0.x prior to 5.0u3g, 5.1.x prior to 5.1u3d, or 5.5.x prior to 5.5u2d. It is, therefore, affected by a reflected cross-site scripting (XSS) vulnerability due to improper sanitization of input. An unauthenticated, remote attacker can exploit this issue, by convincing a user into clicking a malicious link, to execute arbitrary scripting code in the user's browser session.


Upgrade to VMware vCenter Server version 5.0u3g (5.0.0 build-3891026) / 5.1u3d (5.1.0 build-3814779) / 5.5u2d (5.5.0 build-2442329) or later.

Note that the client side component of the vSphere Web Client does not need to be updated to remediate CVE-2015-6931. Updating the vCenter Server is sufficient to remediate this issue.

See Also


Plugin Details

Severity: Medium

ID: 91713

File Name: vmware_vcenter_vmsa-2016-0009.nasl

Version: 1.6

Type: remote

Published: 6/20/2016

Updated: 11/19/2019

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2015-6931


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Required KB Items: Host/VMware/vCenter, Host/VMware/version, Host/VMware/release

Exploit Ease: No exploit is required

Patch Publication Date: 3/15/2016

Vulnerability Publication Date: 6/14/2016

Reference Information

CVE: CVE-2015-6931

VMSA: 2016-0009