VMware vCenter Server 5.0.x < 5.0u3g / 5.1.x < 5.1u3d / 5.5.x < 5.5u2d Reflected XSS (VMSA-2016-0009)
Medium Nessus Plugin ID 91713
SynopsisA virtualization management application installed on the remote host is affected by a reflected cross-site scripting vulnerability.
DescriptionThe version of VMware vCenter Server installed on the remote host is 5.0.x prior to 5.0u3g, 5.1.x prior to 5.1u3d, or 5.5.x prior to 5.5u2d. It is, therefore, affected by a reflected cross-site scripting (XSS) vulnerability due to improper sanitization of input. An unauthenticated, remote attacker can exploit this issue, by convincing a user into clicking a malicious link, to execute arbitrary scripting code in the user's browser session.
SolutionUpgrade to VMware vCenter Server version 5.0u3g (5.0.0 build-3891026) / 5.1u3d (5.1.0 build-3814779) / 5.5u2d (5.5.0 build-2442329) or later.
Note that the client side component of the vSphere Web Client does not need to be updated to remediate CVE-2015-6931. Updating the vCenter Server is sufficient to remediate this issue.