openSUSE Security Update : libksba (openSUSE-2016-697)

Medium Nessus Plugin ID 91532


The remote openSUSE host is missing a security update.


This update for libksba fixes the following issues :

- CVE-2016-4579: Out-of-bounds read in

- CVE-2016-4574: two OOB read access bugs (remote DoS) (bsc#979261)

Also adding reliability fixes from v1.3.4.

This update was imported from the SUSE:SLE-12:Update update project.


Update the affected libksba packages.

See Also

Plugin Details

Severity: Medium

ID: 91532

File Name: openSUSE-2016-697.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2016/06/09

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libksba-debugsource, p-cpe:/a:novell:opensuse:libksba-devel, p-cpe:/a:novell:opensuse:libksba8, p-cpe:/a:novell:opensuse:libksba8-debuginfo, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/06/08

Reference Information

CVE: CVE-2016-4574, CVE-2016-4579