FreeBSD : openafs -- local DoS vulnerability (2e8fe57e-2b46-11e6-ae88-002590263bf5)

Medium Nessus Plugin ID 91476


The remote FreeBSD host is missing a security-related update.


The OpenAFS development team reports :

Avoid a potential denial of service issue, by fixing a bug in pioctl logic that allowed a local user to overrun a kernel buffer with a single NUL byte.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 91476

File Name: freebsd_pkg_2e8fe57e2b4611e6ae88002590263bf5.nasl

Version: $Revision: 2.2 $

Type: local

Published: 2016/06/06

Modified: 2016/10/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.9

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:C


Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:openafs, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/06/05

Vulnerability Publication Date: 2016/03/16

Reference Information

CVE: CVE-2015-8312