openSUSE Security Update : redis (openSUSE-2016-663)

Medium Nessus Plugin ID 91410


The remote openSUSE host is missing a security update.


This update for redis fixes the following security issue :

- CVE-2015-8080: Fixed an integer overflow resulting in stack-based overflow. (bsc#954199)


Update the affected redis packages.

See Also

Plugin Details

Severity: Medium

ID: 91410

File Name: openSUSE-2016-663.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2016/06/01

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:redis, p-cpe:/a:novell:opensuse:redis-debuginfo, p-cpe:/a:novell:opensuse:redis-debugsource, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/05/30

Reference Information

CVE: CVE-2015-8080