openSUSE Security Update : mercurial (openSUSE-2016-609)

Medium Nessus Plugin ID 91279


The remote openSUSE host is missing a security update.


This update for mercurial fixes the following issues :

Security issue fixed :

- CVE-2016-3105: Fixed arbitrary code execution whenusing the convert extension on Git repo. (boo#978391)


Update the affected mercurial packages.

See Also

Plugin Details

Severity: Medium

ID: 91279

File Name: openSUSE-2016-609.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2016/05/20

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mercurial, p-cpe:/a:novell:opensuse:mercurial-debuginfo, p-cpe:/a:novell:opensuse:mercurial-debugsource, p-cpe:/a:novell:opensuse:mercurial-lang, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/05/18

Reference Information

CVE: CVE-2016-3105