Squid 2.x / 3.x < 3.5.17 / 4.x < 4.0.9 cachemgr.cgi RCE

high Nessus Plugin ID 91194


The remote proxy server is affected by a remote code execution vulnerability.


According to its banner, the version of Squid running on the remote host is 2.x or 3.x prior to 3.5.17, or 4.x prior to 4.0.9. It is, therefore, affected by a buffer overflow condition in the cachemgr.cgi tool due to improper validation of user-supplied input when processing the length of content lines in reports by the cachemgr.cgi tool. An unauthenticated, remote attacker can exploit this issue, via specially crafted data in manager reports, to cause a denial of service condition or the execution of arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number. Furthermore, the patch released to address this issue does not update the version given in the banner. If the patch has been applied properly, and the service has been restarted, then consider this to be a false positive.


Upgrade to Squid version 3.5.17 / 4.0.9 or later. Alternatively, apply the vendor-supplied patch.

See Also



Plugin Details

Severity: High

ID: 91194

File Name: squid_4_0_9_cachemgr_cgi.nasl

Version: 1.5

Type: remote

Family: Firewalls

Published: 5/17/2016

Updated: 11/19/2019

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2016-4051


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/20/2016

Vulnerability Publication Date: 4/20/2016

Reference Information

CVE: CVE-2016-4051