FreeBSD : libarchive -- RCE vulnerability (2b4c8e1f-1609-11e6-b55e-b499baebfeaf)

Medium Nessus Plugin ID 91026


The remote FreeBSD host is missing a security-related update.


The libarchive project reports :

Heap-based buffer overflow in the zip_read_mac_metadata function in archive_read_support_format_zip.c in libarchive before 3.2.0 allows remote attackers to execute arbitrary code via crafted entry-size values in a ZIP archive.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 91026

File Name: freebsd_pkg_2b4c8e1f160911e6b55eb499baebfeaf.nasl

Version: $Revision: 2.3 $

Type: local

Published: 2016/05/11

Modified: 2016/10/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libarchive, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/05/09

Vulnerability Publication Date: 2016/05/01

Reference Information

CVE: CVE-2016-1541