VMware vRealize Automation 6.x < 6.2.4 Unspecified Stored XSS (VMSA-2016-0003)

Low Nessus Plugin ID 90763

Synopsis

A device management application running on the remote host is affected by a stored cross-site-scripting vulnerability.

Description

The VMware vRealize Automation application running on the remote host is 6.x prior to 6.2.4. It is, therefore, affected by an unspecified stored cross-site scripting vulnerability due to improper validation of user-supplied input. A remote attacker can exploit this by convincing a user to follow a specially crafted request, resulting in the execution of arbitrary script code in a user's browser session.

Solution

Upgrade to VMware vRealize Automation version 6.2.4 or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2016-0003

http://seclists.org/fulldisclosure/2016/Mar/55

Plugin Details

Severity: Low

ID: 90763

File Name: vmware_vrealize_automation_VMSA_2016_003.nasl

Version: 1.3

Type: combined

Published: 2016/04/27

Modified: 2018/08/06

Dependencies: 12634, 90764

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.5

Temporal Score: 3

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vrealize_automation

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2016/03/15

Vulnerability Publication Date: 2016/03/15

Reference Information

CVE: CVE-2015-2344

VMSA: 2016-0003