openSUSE Security Update : optipng (openSUSE-2016-469)

High Nessus Plugin ID 90561


The remote openSUSE host is missing a security update.


optipng was updated to fix one security issue.

This security issue was fixed :

- CVE-2016-2191: Invalid write while processing bitmap images (bsc#973992).

- CVE-2016-3981: Heap buffer overflow pngxrbmp.c bmp_read_rows

- CVE-2016-3982: Heap buffer overflow pngxrbmp.c bmp_rle4_fread


Update the affected optipng packages.

See Also

Plugin Details

Severity: High

ID: 90561

File Name: openSUSE-2016-469.nasl

Version: $Revision: 2.4 $

Type: local

Agent: unix

Published: 2016/04/18

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:optipng, p-cpe:/a:novell:opensuse:optipng-debuginfo, p-cpe:/a:novell:opensuse:optipng-debugsource, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/04/17

Reference Information

CVE: CVE-2016-2191, CVE-2016-3981, CVE-2016-3982