openSUSE Security Update : mercurial (openSUSE-2016-467)

Medium Nessus Plugin ID 90559


The remote openSUSE host is missing a security update.


mercurial was updated to fix three security issues.

These security issues were fixed :

- CVE-2016-3069: Arbitrary code execution when converting Git repos (bsc#973176).

- CVE-2016-3068: Arbitrary code execution with Git subrepos (bsc#973177).

- CVE-2016-3630: Remote code execution in binary delta decoding (bsc#973175).


Update the affected mercurial packages.

See Also

Plugin Details

Severity: Medium

ID: 90559

File Name: openSUSE-2016-467.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2016/04/18

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mercurial, p-cpe:/a:novell:opensuse:mercurial-debuginfo, p-cpe:/a:novell:opensuse:mercurial-debugsource, p-cpe:/a:novell:opensuse:mercurial-lang, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/04/17

Reference Information

CVE: CVE-2016-3068, CVE-2016-3069, CVE-2016-3630