Piwik < 2.16.0 Unspecified XSS

Medium Nessus Plugin ID 90537


A web application hosted on the remote web server is affected by a cross-site scripting vulnerability.


The version of Piwik running on the remote host is prior to 2.16.0.
It is, therefore, affected by an unspecified cross-site scripting (XSS) vulnerability due to a failure to properly validate input before returning it to users. An unauthenticated, remote attacker can exploit this, via a crafted request, to execute arbitrary script code in a user's browser session.


Upgrade to Piwik version 2.16.0 or later. If necessary, remove any affected versions.

See Also


Plugin Details

Severity: Medium

ID: 90537

File Name: piwik_2_16_0.nasl

Version: $Revision: 1.2 $

Type: remote

Published: 2016/04/15

Modified: 2016/04/29

Dependencies: 63078

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:piwik:piwik

Required KB Items: installed_sw/Piwik, www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/02/04

Vulnerability Publication Date: 2016/02/04

Reference Information

OSVDB: 134025