SUSE SLES11 Security Update : samba (SUSE-SU-2016:1023-1) (Badlock)

high Nessus Plugin ID 90533

Synopsis

The remote SUSE host is missing one or more security updates.

Description

samba was updated to fix seven security issues.

These security issues were fixed :

- CVE-2015-5370: DCERPC server and client were vulnerable to DOS and MITM attacks (bsc#936862).

- CVE-2016-2110: A man-in-the-middle could have downgraded NTLMSSP authentication (bsc#973031).

- CVE-2016-2111: Domain controller netlogon member computer could have been spoofed (bsc#973032).

- CVE-2016-2112: LDAP conenctions were vulnerable to downgrade and MITM attack (bsc#973033).

- CVE-2016-2113: TLS certificate validation were missing (bsc#973034).

- CVE-2016-2115: Named pipe IPC were vulnerable to MITM attacks (bsc#973036).

- CVE-2016-2118: 'Badlock' DCERPC impersonation of authenticated account were possible (bsc#971965).

The update package also includes non-security fixes. See advisory for details.

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE OpenStack Cloud 5 :

zypper in -t patch sleclo50sp3-samba-12507=1

SUSE Manager Proxy 2.1 :

zypper in -t patch slemap21-samba-12507=1

SUSE Manager 2.1 :

zypper in -t patch sleman21-samba-12507=1

SUSE Linux Enterprise Software Development Kit 11-SP4 :

zypper in -t patch sdksp4-samba-12507=1

SUSE Linux Enterprise Software Development Kit 11-SP3 :

zypper in -t patch sdksp3-samba-12507=1

SUSE Linux Enterprise Server 11-SP4 :

zypper in -t patch slessp4-samba-12507=1

SUSE Linux Enterprise Server 11-SP3-LTSS :

zypper in -t patch slessp3-samba-12507=1

SUSE Linux Enterprise Debuginfo 11-SP4 :

zypper in -t patch dbgsp4-samba-12507=1

SUSE Linux Enterprise Debuginfo 11-SP3 :

zypper in -t patch dbgsp3-samba-12507=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=936862

https://bugzilla.suse.com/show_bug.cgi?id=967017

https://bugzilla.suse.com/show_bug.cgi?id=971965

https://bugzilla.suse.com/show_bug.cgi?id=973031

https://bugzilla.suse.com/show_bug.cgi?id=973032

https://bugzilla.suse.com/show_bug.cgi?id=973033

https://bugzilla.suse.com/show_bug.cgi?id=973034

https://bugzilla.suse.com/show_bug.cgi?id=973036

https://www.suse.com/security/cve/CVE-2015-5370/

https://www.suse.com/security/cve/CVE-2016-2110/

https://www.suse.com/security/cve/CVE-2016-2111/

https://www.suse.com/security/cve/CVE-2016-2112/

https://www.suse.com/security/cve/CVE-2016-2113/

https://www.suse.com/security/cve/CVE-2016-2115/

https://www.suse.com/security/cve/CVE-2016-2118/

http://www.nessus.org/u?4a6d1c5e

Plugin Details

Severity: High

ID: 90533

File Name: suse_SU-2016-1023-1.nasl

Version: 2.17

Type: local

Agent: unix

Published: 4/15/2016

Updated: 1/19/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:ldapsmb, p-cpe:/a:novell:suse_linux:libldb1, p-cpe:/a:novell:suse_linux:libsmbclient0, p-cpe:/a:novell:suse_linux:libtalloc2, p-cpe:/a:novell:suse_linux:libtdb1, p-cpe:/a:novell:suse_linux:libtevent0, p-cpe:/a:novell:suse_linux:libwbclient0, p-cpe:/a:novell:suse_linux:samba, p-cpe:/a:novell:suse_linux:samba-client, p-cpe:/a:novell:suse_linux:samba-krb-printing, p-cpe:/a:novell:suse_linux:samba-winbind, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 4/12/2016

Vulnerability Publication Date: 4/12/2016

Reference Information

CVE: CVE-2015-5370, CVE-2016-2110, CVE-2016-2111, CVE-2016-2112, CVE-2016-2113, CVE-2016-2115, CVE-2016-2118