openSUSE Security Update : perl (openSUSE-2016-386)

High Nessus Plugin ID 90164


The remote openSUSE host is missing a security update.


This update for perl fixes the following issues :

- CVE-2016-2381: Fixed environment duplicated variable handling bug [boo#967082]

- fix memory leak in 'use utf8' handling [boo#928292]

- CVE-2015-8607: Fixed taint propagation in canonpath [boo#961528]


Update the affected perl packages.

See Also

Plugin Details

Severity: High

ID: 90164

File Name: openSUSE-2016-386.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2016/03/25

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl, p-cpe:/a:novell:opensuse:perl-32bit, p-cpe:/a:novell:opensuse:perl-base, p-cpe:/a:novell:opensuse:perl-base-32bit, p-cpe:/a:novell:opensuse:perl-base-debuginfo, p-cpe:/a:novell:opensuse:perl-base-debuginfo-32bit, p-cpe:/a:novell:opensuse:perl-debuginfo, p-cpe:/a:novell:opensuse:perl-debuginfo-32bit, p-cpe:/a:novell:opensuse:perl-debugsource, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/03/24

Reference Information

CVE: CVE-2015-8607, CVE-2016-2381