PHP 5.5.x < 5.5.33 Multiple Vulnerabilities

High Nessus Plugin ID 90007

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 5.5.x prior to 5.5.33. It is, therefore, affected by multiple vulnerabilities :

- A use-after-free error exists in file ext/wddx/wddx.c in the php_wddx_pop_element() function when handling XML data. An unauthenticated, remote attacker can exploit this, via crafted XML data, to dereference already freed memory, resulting in the execution of arbitrary code.
(CVE-2016-3141)

- An out-of-bounds read error exists in file ext/phar/zip.c in the phar_parse_zipfile() function that allows an unauthenticated, remote attacker to cause a denial of service or to gain access to sensitive information. (CVE-2016-3142)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.5.33 or later.

See Also

http://php.net/ChangeLog-5.php#5.5.33

Plugin Details

Severity: High

ID: 90007

File Name: php_5_5_33.nasl

Version: 1.14

Type: remote

Family: CGI abuses

Published: 2016/03/17

Updated: 2019/11/20

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-3141

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2016/03/03

Vulnerability Publication Date: 2016/03/02

Reference Information

CVE: CVE-2016-3141, CVE-2016-3142

BID: 84271, 84306, 84307, 84348, 84349, 84350, 84351