CVE-2016-3141

CRITICAL
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Use-after-free vulnerability in wddx.c in the WDDX extension in PHP before 5.5.33 and 5.6.x before 5.6.19 allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact by triggering a wddx_deserialize call on XML data containing a crafted var element.

References

http://git.php.net/?p=php-src.git;a=commit;h=b1bd4119bcafab6f9a8f84d92cd65eec3afeface

http://lists.apple.com/archives/security-announce/2016/May/msg00004.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00052.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00056.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00057.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00058.html

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.oracle.com/technetwork/topics/security/bulletinoct2016-3090566.html

http://www.securityfocus.com/bid/84271

http://www.securitytracker.com/id/1035255

http://www.ubuntu.com/usn/USN-2952-1

http://www.ubuntu.com/usn/USN-2952-2

https://bugs.php.net/bug.php?id=71587

https://php.net/ChangeLog-5.php

https://support.apple.com/HT206567

Details

Source: MITRE

Published: 2016-03-31

Updated: 2018-01-05

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
98808PHP 5.6.x < 5.6.19 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119975SUSE SLES12 Security Update : php5 (SUSE-SU-2016:1166-1)NessusSuSE Local Security Checks
critical
97052Debian DLA-818-1 : php5 security updateNessusDebian Local Security Checks
critical
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
9392Mac OS X 10.11.x < 10.11.5 Multiple VulnerabilitiesNessus Network MonitorOperating System Detection
high
91665SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1581-1)NessusSuSE Local Security Checks
critical
91228Mac OS X 10.11.x < 10.11.5 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
90825Ubuntu 15.10 : php5 regression (USN-2952-2)NessusUbuntu Local Security Checks
critical
90782openSUSE Security Update : php5 (openSUSE-2016-517)NessusSuSE Local Security Checks
critical
90772openSUSE Security Update : php5 (openSUSE-2016-516)NessusSuSE Local Security Checks
critical
90757SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1145-1)NessusSuSE Local Security Checks
critical
90677Ubuntu 12.04 LTS / 14.04 LTS / 15.10 : php5 vulnerabilities (USN-2952-1)NessusUbuntu Local Security Checks
critical
9174PHP 5.5.x < 5.5.33 / 5.6.x < 5.6.19 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
90008PHP 5.6.x < 5.6.19 Multiple VulnerabilitiesNessusCGI abuses
critical
90007PHP 5.5.x < 5.5.33 Multiple VulnerabilitiesNessusCGI abuses
critical