openSUSE Security Update : rubygem-actionview-4_2 (openSUSE-2016-352)

High Nessus Plugin ID 89977


The remote openSUSE host is missing a security update.


This update for rubygem-actionview-4_2 fixes the following issues :

- CVE-2016-2098: rubygem-actionpack: Possible remote code execution vulnerability in Action Pack (boo#968849)


Update the affected rubygem-actionview-4_2 packages.

See Also

Plugin Details

Severity: High

ID: 89977

File Name: openSUSE-2016-352.nasl

Version: $Revision: 2.7 $

Type: local

Agent: unix

Published: 2016/03/17

Modified: 2016/12/07

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ruby2.1-rubygem-actionview-4_2, p-cpe:/a:novell:opensuse:ruby2.1-rubygem-actionview-doc-4_2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/03/16

Exploitable With


Core Impact

Metasploit (Ruby on Rails ActionPack Inline ERB Code Execution)

Reference Information

CVE: CVE-2016-2098