openSUSE Security Update : nghttp2 (openSUSE-2016-314)

low Nessus Plugin ID 89812
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for nghttp2 fixes the following vulnerabilities :

- CVE-2016-1544: A malicious remote attacker could have caused an Out of memory condition due to unlimited incoming HTTP header fields (boo#966514)

Solution

Update the affected nghttp2 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=966514

Plugin Details

Severity: Low

ID: 89812

File Name: openSUSE-2016-314.nasl

Version: 2.4

Type: local

Agent: unix

Published: 3/10/2016

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Low

Base Score: 2.1

Vector: AV:L/AC:L/Au:N/C:N/I:N/A:P

CVSS v3

Risk Factor: Low

Base Score: 3.3

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libnghttp2-14, p-cpe:/a:novell:opensuse:libnghttp2-14-debuginfo, p-cpe:/a:novell:opensuse:libnghttp2-devel, p-cpe:/a:novell:opensuse:libnghttp2_asio-devel, p-cpe:/a:novell:opensuse:libnghttp2_asio1, p-cpe:/a:novell:opensuse:libnghttp2_asio1-debuginfo, p-cpe:/a:novell:opensuse:nghttp2, p-cpe:/a:novell:opensuse:nghttp2-debuginfo, p-cpe:/a:novell:opensuse:nghttp2-debugsource, p-cpe:/a:novell:opensuse:python-nghttp2, p-cpe:/a:novell:opensuse:python-nghttp2-debuginfo, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 3/7/2016

Vulnerability Publication Date: 2/6/2020

Reference Information

CVE: CVE-2016-1544