MySQL 5.7.x < 5.7.11 Multiple Vulnerabilities

Medium Nessus Plugin ID 89056

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.7.x prior to 5.7.11. It is, therefore, potentially affected by multiple vulnerabilities :

- A NULL pointer dereference flaw exists in the bundled version of OpenSSL in file rsa_ameth.c due to improper handling of ASN.1 signatures that are missing the PSS parameter. A remote attacker can exploit this to cause the signature verification routine to crash, resulting in a denial of service condition. (CVE-2015-3194)

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to impact integrity and availability. (CVE-2016-0640)

- An unspecified flaw exists in the MyISAM subcomponent that allows an authenticated, remote attacker to disclose sensitive information or cause a denial of service condition. (CVE-2016-0641)

- An unspecified flaw exists in the DDL subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0644)

- Multiple unspecified flaws exist in the DML subcomponent that allow an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0646, CVE-2016-0652)

- An unspecified flaw exists in the PS subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0649)

- An unspecified flaw exists in the Replication subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-0650)

- An unspecified flaw exists in the FTS subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0653)

- Multiple unspecified flaws exist in the InnoDB subcomponent that allow an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-0654, CVE-2016-0656, CVE-2016-0668)

- An unspecified flaw exists in the Optimizer subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0658)

- An unspecified flaw exists in the Options subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0661)

- An unspecified flaw exists in the Performance Schema subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-0663)

- An unspecified flaw exists in the Security: Encryption subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-0665)

- A denial of service vulnerability exists in the bundled OpenSSL library due to improper handling of variables declared as TEXT or BLOB. An authenticated, remote attacker can exploit this to corrupt data or cause a denial of service condition.

- A denial of service vulnerability exists that is triggered when handling a 'CREATE TEMPORARY TABLE ..
SELECT' statement involving BIT columns. An authenticated, remote attacker can exploit this to create an improper table or cause the server to exit, resulting in a denial of service condition.

- A denial of service vulnerability exists due to improper handling of queries that contain 'WHERE 0'. An authenticated, remote attacker can exploit this to cause an uninitialized read, resulting in a denial of service condition.

Solution

Upgrade to MySQL version 5.7.11 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-11.html

http://www.nessus.org/u?a0defed6

Plugin Details

Severity: Medium

ID: 89056

File Name: mysql_5_7_11.nasl

Version: 1.11

Type: remote

Family: Databases

Published: 2016/03/01

Updated: 2019/01/02

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/05

Vulnerability Publication Date: 2015/12/03

Reference Information

CVE: CVE-2015-3194, CVE-2016-0640, CVE-2016-0641, CVE-2016-0644, CVE-2016-0646, CVE-2016-0649, CVE-2016-0650, CVE-2016-0652, CVE-2016-0653, CVE-2016-0654, CVE-2016-0656, CVE-2016-0658, CVE-2016-0661, CVE-2016-0663, CVE-2016-0665, CVE-2016-0668