MySQL 5.5.x < 5.5.48 Multiple Vulnerabilities

High Nessus Plugin ID 89054

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.5.x prior to 5.5.48. It is, therefore, affected by multiple vulnerabilities :

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to impact integrity and availability. (CVE-2016-0640)

- An unspecified flaw exists in the MyISAM subcomponent that allows an authenticated, remote attacker to disclose sensitive information or cause a denial of service condition. (CVE-2016-0641)

- An unspecified flaw exists in the DDL subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0644)

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0646)

- An unspecified flaw exists in the PS subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-0649)

- An unspecified flaw exists in the Replication subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-0650)

- A denial of service vulnerability exists in the bundled OpenSSL library due to improper handling of variables declared as TEXT or BLOB. An authenticated, remote attacker can exploit this to corrupt data or cause a denial of service condition.

- A denial of service vulnerability exists that is triggered when handling a 'CREATE TEMPORARY TABLE ..
SELECT' statement involving BIT columns. An authenticated, remote attacker can exploit this to create an improper table or cause the server to exit, resulting in a denial of service condition.

- A denial of service vulnerability exists due to an unspecified flaw in LOCK TABLES that is triggered when opening a temporary MERGE table consisting of a view in the list of tables. An authenticated, remote attacker can exploit this to cause the server to exit, resulting in a denial of service condition.

Solution

Upgrade to MySQL version 5.5.48 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-48.html

http://www.nessus.org/u?a0defed6

Plugin Details

Severity: High

ID: 89054

File Name: mysql_5_5_48.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 2016/03/01

Updated: 2019/04/04

Dependencies: 10719, 91823

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Composite vector of multiple vulnerabilities in the given version

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/05

Vulnerability Publication Date: 2015/12/03

Reference Information

CVE: CVE-2016-0640, CVE-2016-0641, CVE-2016-0644, CVE-2016-0646, CVE-2016-0649, CVE-2016-0650