Squid 3.5.13 / 4.0.4 / 4.0.5 Server Connection Error Handling DoS

Medium Nessus Plugin ID 89052


The remote proxy server is potentially affected by a denial of service vulnerability.


According to its banner, the version of Squid running on the remote host is 3.5.13, 4.0.4, or 4.0.5. It is, therefore, potentially affected by a denial of service vulnerability due to improper handling of server connection errors in the FwdState::connectedToPeer() function. A remote attacker can exploit this, via a misconfigured client or server, to cause a denial of service condition when connecting to TLS or SSL servers.

Note that only servers built with the --with-openssl option are vulnerable.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number. The patch released to address this issue does not update the version given in the banner. If the patch has been applied properly, and the service has been restarted, consider this to be a false positive.


Upgrade to Squid version 3.5.14 / 4.0.6 or later. Alternatively, apply the vendor-supplied patch.

See Also


Plugin Details

Severity: Medium

ID: 89052

File Name: squid_4_0_6.nasl

Version: 1.5

Type: remote

Family: Firewalls

Published: 2016/03/01

Updated: 2019/11/20

Dependencies: 49692

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2016-2390

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/12

Vulnerability Publication Date: 2016/02/16

Reference Information

CVE: CVE-2016-2390

BID: 83261