FreeBSD : wireshark -- multiple vulnerabilities (45117749-df55-11e5-b2bd-002590263bf5)

High Nessus Plugin ID 89048


The remote FreeBSD host is missing one or more security-related updates.


Wireshark development team reports :

The following vulnerabilities have been fixed :

- wnpa-sec-2016-02

ASN.1 BER dissector crash. (Bug 11828) CVE-2016-2522

- wnpa-sec-2016-03

DNP dissector infinite loop. (Bug 11938) CVE-2016-2523

- wnpa-sec-2016-04

X.509AF dissector crash. (Bug 12002) CVE-2016-2524

- wnpa-sec-2016-05

HTTP/2 dissector crash. (Bug 12077) CVE-2016-2525

- wnpa-sec-2016-06

HiQnet dissector crash. (Bug 11983) CVE-2016-2526

- wnpa-sec-2016-07

3GPP TS 32.423 Trace file parser crash. (Bug 11982)


- wnpa-sec-2016-08

LBMC dissector crash. (Bug 11984) CVE-2016-2528

- wnpa-sec-2016-09

iSeries file parser crash. (Bug 11985) CVE-2016-2529

- wnpa-sec-2016-10

RSL dissector crash. (Bug 11829) CVE-2016-2530 CVE-2016-2531

- wnpa-sec-2016-11

LLRP dissector crash. (Bug 12048) CVE-2016-2532

- wnpa-sec-2016-12

Ixia IxVeriWave file parser crash. (Bug 11795)

- wnpa-sec-2016-13

IEEE 802.11 dissector crash. (Bug 11818)

- wnpa-sec-2016-14

GSM A-bis OML dissector crash. (Bug 11825)

- wnpa-sec-2016-15

ASN.1 BER dissector crash. (Bug 12106)

- wnpa-sec-2016-16

SPICE dissector large loop. (Bug 12151)

- wnpa-sec-2016-17

NFS dissector crash.

- wnpa-sec-2016-18

ASN.1 BER dissector crash. (Bug 11822)


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 89048

File Name: freebsd_pkg_45117749df5511e5b2bd002590263bf5.nasl

Version: $Revision: 2.7 $

Type: local

Published: 2016/03/01

Modified: 2016/10/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C


Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:tshark, p-cpe:/a:freebsd:freebsd:tshark-lite, p-cpe:/a:freebsd:freebsd:wireshark, p-cpe:/a:freebsd:freebsd:wireshark-lite, p-cpe:/a:freebsd:freebsd:wireshark-qt5, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/03/01

Vulnerability Publication Date: 2016/02/26

Reference Information

CVE: CVE-2016-2522, CVE-2016-2523, CVE-2016-2524, CVE-2016-2525, CVE-2016-2526, CVE-2016-2527, CVE-2016-2528, CVE-2016-2529, CVE-2016-2530, CVE-2016-2531, CVE-2016-2532, CVE-2016-4415, CVE-2016-4416, CVE-2016-4417, CVE-2016-4418, CVE-2016-4419, CVE-2016-4420, CVE-2016-4421