openSUSE Security Update : nodejs (openSUSE-2016-283)

Medium Nessus Plugin ID 89019


The remote openSUSE host is missing a security update.


This update for nodejs fixes the following issues :

- CVE-2016-2216: Response splitting vulnerability using Unicode characters (boo#966076)

- CVE-2016-2086: Request smuggling vulnerability (boo#966077)

Node.js was updated to the 4.3.1 LTS version, containing all upstream bug fixes and improvements.


Update the affected nodejs packages.

See Also

Plugin Details

Severity: Medium

ID: 89019

File Name: openSUSE-2016-283.nasl

Version: $Revision: 2.4 $

Type: local

Agent: unix

Published: 2016/02/29

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nodejs, p-cpe:/a:novell:opensuse:nodejs-debuginfo, p-cpe:/a:novell:opensuse:nodejs-debugsource, p-cpe:/a:novell:opensuse:nodejs-devel, p-cpe:/a:novell:opensuse:npm, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/02/28

Reference Information

CVE: CVE-2016-2086, CVE-2016-2216