Tenable Nessus < 6.5.5 Host Details Scan Results XSS

Low Nessus Plugin ID 88904


The remote Nessus installation is affected by a cross-site scripting vulnerability.


According to its version, the Tenable Nessus application running on the remote host is prior to 6.5.5. It is, therefore, affected by a cross-site scripting (XSS) vulnerability in the Host Details section due to improper sanitization of user-supplied input. An unauthenticated, remote attacker can exploit this, via importing a malicious file or by scanning a malicious host that returns JavaScript instead of a hostname, to introduce and store JavaScript in the scan results, which can be later executed in the context of the user viewing the results.


Upgrade to Tenable Nessus version 6.5.5 or later.

See Also


Plugin Details

Severity: Low

ID: 88904

File Name: nessus_tns_2016_02.nasl

Version: $Revision: 1.6 $

Type: remote

Published: 2016/02/23

Modified: 2017/03/07

Dependencies: 10147

Risk Information

Risk Factor: Low


Base Score: 2.6

Temporal Score: 2.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 3.4

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/01/28

Vulnerability Publication Date: 2015/02/15

Reference Information

CVE: CVE-2016-82000

OSVDB: 134521