Tenable Nessus < 6.5.5 Host Details Scan Results XSS

low Nessus Plugin ID 88904


The remote Nessus installation is affected by a cross-site scripting vulnerability.


According to its version, the Tenable Nessus application running on the remote host is prior to 6.5.5. It is, therefore, affected by a cross-site scripting (XSS) vulnerability in the Host Details section due to improper sanitization of user-supplied input. An unauthenticated, remote attacker can exploit this, via importing a malicious file or by scanning a malicious host that returns JavaScript instead of a hostname, to introduce and store JavaScript in the scan results, which can be later executed in the context of the user viewing the results.


Upgrade to Tenable Nessus version 6.5.5 or later.

See Also


Plugin Details

Severity: Low

ID: 88904

File Name: nessus_tns_2016_02.nasl

Version: 1.8

Type: remote

Published: 2/23/2016

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Low

Score: 1.6


Risk Factor: Low

Base Score: 2.6

Temporal Score: 2.3

Vector: AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C


Risk Factor: Low

Base Score: 3.4

Temporal Score: 3.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Ease: No exploit is required

Patch Publication Date: 1/28/2015

Vulnerability Publication Date: 2/15/2015

Reference Information

CVE: CVE-2016-82000