Fortinet FortiWeb 5.1.2 < 5.3.5 Autolearn Configuration Multiple XSS

Medium Nessus Plugin ID 88842

Synopsis

The remote host is affected by multiple cross-site scripting vulnerabilities.

Description

The remote FortiWeb device is running a software version greater than or equal to 5.1.2 and less than 5.3.5. It is, therefore, affected by multiple cross-site scripting vulnerabilities due to improper validation of user-supplied input to the autolearn configuration page.
An attacker can exploit these vulnerabilities, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Solution

Upgrade to Fortinet FortiWeb version 5.2.3 or later.

See Also

https://fortiguard.com/psirt/FG-IR-15-005

Plugin Details

Severity: Medium

ID: 88842

File Name: fortiweb_FG-IR-15-005.nasl

Version: 1.4

Type: local

Published: 2016/02/18

Modified: 2018/11/15

Dependencies: 73522

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:fortinet:fortiweb

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2015/02/25

Vulnerability Publication Date: 2015/02/25

Reference Information

CVE: CVE-2014-8619

BID: 74679