Fortinet FortiWeb 5.1.2 < 5.3.5 Autolearn Configuration Multiple XSS

medium Nessus Plugin ID 88842


The remote host is affected by multiple cross-site scripting vulnerabilities.


The remote FortiWeb device is running a software version greater than or equal to 5.1.2 and less than 5.3.5. It is, therefore, affected by multiple cross-site scripting vulnerabilities due to improper validation of user-supplied input to the autolearn configuration page.
An attacker can exploit these vulnerabilities, via a specially crafted request, to execute arbitrary script code in a user's browser session.


Upgrade to Fortinet FortiWeb version 5.2.3 or later.

See Also

Plugin Details

Severity: Medium

ID: 88842

File Name: fortiweb_FG-IR-15-005.nasl

Version: 1.4

Type: local

Published: 2/18/2016

Updated: 11/15/2018

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:fortinet:fortiweb

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Ease: No exploit is required

Patch Publication Date: 2/25/2015

Vulnerability Publication Date: 2/25/2015

Reference Information

CVE: CVE-2014-8619

BID: 74679