Fortinet FortiADC Model D < 4.2 Theme Login Page XSS

Medium Nessus Plugin ID 88840

Synopsis

The remote host is affected by a cross-site scripting vulnerability.

Description

The remote FortiADC Model D device is running a software version less than 4.2. It is, therefore, affected by a cross-site scripting vulnerability due to improper validation of user-supplied input to the theme login page. An attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Solution

Upgrade to Fortinet FortiADC version 4.2 or later.

See Also

https://fortiguard.com/psirt/FG-IR-15-005

Plugin Details

Severity: Medium

ID: 88840

File Name: fortiadc_FG-IR-15-005.nasl

Version: 1.4

Type: local

Published: 2016/02/18

Modified: 2018/11/15

Dependencies: 73522

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:fortinet:fortiadc_firmware

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2015/02/25

Vulnerability Publication Date: 2015/02/25

Reference Information

CVE: CVE-2014-8618

BID: 74678