openSUSE Security Update : socat (openSUSE-2016-218) (Logjam)

Medium Nessus Plugin ID 88824

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for socat fixes the following issues :

Changes in socat :

- update to 1.7.3.1, security fixes :

- Socat security advisory 7 and MSVR-1499: 'Bad DH p parameter in OpenSSL' (boo#938913 and CVE-2015-4000).

- Socat security advisory 8: 'Stack overflow in arguments parser' (boo#964844)

- Update to version 1.7.3.0

- Too many changes to list; please read the CHANGES file for news

Solution

Update the affected socat packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=938913

https://bugzilla.opensuse.org/show_bug.cgi?id=964844

Plugin Details

Severity: Medium

ID: 88824

File Name: openSUSE-2016-218.nasl

Version: Revision: 2.2

Type: local

Agent: unix

Published: 2016/02/18

Updated: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 3.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:socat, p-cpe:/a:novell:opensuse:socat-debuginfo, p-cpe:/a:novell:opensuse:socat-debugsource, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/02/16

Reference Information

CVE: CVE-2015-4000