openSUSE Security Update : cacti (openSUSE-2016-201)

High Nessus Plugin ID 88734


The remote openSUSE host is missing a security update.


cacti was updated to fix the following vulnerabilities :

- CVE-2015-8369: SQL injection in graph.php (boo#958863)

- CVE-2015-8604: SQL injection in graphs_new.php (boo#960678)

- CVE-2015-8377: SQL injection vulnerability in the host_new_graphs_save function in graphs_new.php (boo#958977)

- CVE-2016-2313: Authentication using web authentication as a user not in the cacti database allows complete access (boo#965930)

The following non-security bugs were fixed :

boo#965864: Poller Script Parser was broken (boo#965864)

cacti-spine was updated to match the cacti version, fixing a number of upstream bugs.


Update the affected cacti package.

See Also

Plugin Details

Severity: High

ID: 88734

File Name: openSUSE-2016-201.nasl

Version: $Revision: 2.2 $

Type: local

Agent: unix

Published: 2016/02/15

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cacti, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2016/02/12

Reference Information

CVE: CVE-2015-8369, CVE-2015-8377, CVE-2015-8604, CVE-2016-2313