ISC BIND 9.9.8-Sx < 9.9.8-S5 REQUIRE Assertion DoS

Medium Nessus Plugin ID 88716

Synopsis

The remote name server is affected by a denial of service vulnerability.

Description

According to its self-reported version number, the version of BIND 9 Supported Preview Edition running on the remote host is version 9.9.8-Sx prior to 9.9.8-S5. It is, therefore, affected by a denial of service vulnerability due to a flaw in file rdataset.c related to handling flag values in incoming queries when the 'nxdomain-redirect' option is enabled. An unauthenticated, remote attacker can exploit this, via a crafted query with the right combination of attributes, to cause a REQUIRE assertion failure, resulting in termination of the service.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Note that 9.9.8-S4 and 9.9.8-S5 are preview versions of BIND provided exclusively to ISC Support customers.

Solution

Upgrade to BIND version 9.9.8-S5 or later. Alternatively, contact the vendor regarding a patch for BIND version 9.9.8-S4.

See Also

https://kb.isc.org/article/AA-01348

Plugin Details

Severity: Medium

ID: 88716

File Name: bind9_998_S5.nasl

Version: 1.3

Type: remote

Family: DNS

Published: 2016/02/12

Modified: 2018/06/27

Dependencies: 10028

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.4

Temporal Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:isc:bind

Required KB Items: bind/version, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/02/03

Vulnerability Publication Date: 2016/02/03

Reference Information

CVE: CVE-2016-1284

BID: 82807