Mac OS X : Apple Safari < 9.0.3 Multiple Vulnerabilities

High Nessus Plugin ID 88597


The remote host has a web browser installed that is affected by multiple vulnerabilities.


The version of Apple Safari installed on the remote Mac OS X host is prior to 9.0.3. It is, therefore, affected by the following vulnerabilities :

- Multiple memory corruption vulnerabilities exist in WebKit due to improper validation of user-supplied input. A remote attacker, via a specially crafted website, can exploit these issues to execute arbitrary code or cause a denial of service. (CVE-2016-1723, CVE-2016-1724, CVE-2016-1725, CVE-2016-1726, CVE-2016-1727)

- A flaw exists in the Cascading Style Sheets (CSS) implementation in WebKit CSS when handling the 'a:visited button' CSS selector while evaluating the height of the containing element. A remote attacker can exploit this, via a crafted website, to obtain sensitive browser history information. (CVE-2016-1728)


Upgrade to Apple Safari version 9.0.3 or later.

See Also

Plugin Details

Severity: High

ID: 88597

File Name: macosx_Safari9_0_3.nasl

Version: $Revision: 1.2 $

Type: local

Agent: macosx

Published: 2016/02/05

Modified: 2016/04/28

Dependencies: 31604

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:UR

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Safari/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/01/19

Vulnerability Publication Date: 2016/01/19

Reference Information

CVE: CVE-2016-1723, CVE-2016-1724, CVE-2016-1725, CVE-2016-1726, CVE-2016-1727, CVE-2016-1728

BID: 81263

OSVDB: 133143, 133144, 133145, 133146, 133147, 133149

APPLE-SA: APPLE-SA-2016-01-19-3