CVE-2016-1726

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

WebKit, as used in Apple iOS before 9.2.1 and Safari before 9.0.3, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1723 and CVE-2016-1725.

References

http://lists.apple.com/archives/security-announce/2016/Jan/msg00002.html

http://lists.apple.com/archives/security-announce/2016/Jan/msg00004.html

http://lists.apple.com/archives/security-announce/2016/Mar/msg00001.html

http://packetstormsecurity.com/files/136227/WebKitGTK-Memory-Corruption-Denial-Of-Service.html

http://www.securityfocus.com/archive/1/537771/100/0/threaded

http://www.securityfocus.com/bid/81263

http://www.securitytracker.com/id/1034737

https://security.gentoo.org/glsa/201706-15

https://support.apple.com/HT205730

https://support.apple.com/HT205732

https://support.apple.com/HT206168

Details

Source: MITRE

Published: 2016-02-01

Updated: 2018-10-09

Type: CWE-119

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:* versions up to 9.0.2 (inclusive)

cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* versions up to 9.2 (inclusive)

cpe:2.3:o:apple:watchos:*:*:*:*:*:*:*:* versions up to 2.1 (inclusive)

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
100675GLSA-201706-15 : WebKitGTK+: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
9330Apple iOS < 9.2.1 Multiple VulnerabilitiesNessus Network MonitorMobile Devices
high
88597Mac OS X : Apple Safari < 9.0.3 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
88050Apple iOS < 9.2.1 Multiple VulnerabilitiesNessusMobile Devices
high