openSUSE Security Update : openssh (openSUSE-2016-49)

Medium Nessus Plugin ID 88157


The remote openSUSE host is missing a security update.


- CVE-2016-0777: A malicious or compromised server could cause the OpenSSH client to expose part or all of the client's private key through the roaming feature (bsc#961642)

- CVE-2016-0778: A malicious or compromised server could could trigger a buffer overflow in the OpenSSH client through the roaming feature (bsc#961645)

This update disables the undocumented feature supported by the OpenSSH client and a commercial SSH server.


Update the affected openssh packages.

See Also

Plugin Details

Severity: Medium

ID: 88157

File Name: openSUSE-2016-49.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2016/01/26

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:N/AC:H/Au:S/C:P/I:P/A:P


Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:openssh, p-cpe:/a:novell:opensuse:openssh-askpass-gnome, p-cpe:/a:novell:opensuse:openssh-askpass-gnome-debuginfo, p-cpe:/a:novell:opensuse:openssh-debuginfo, p-cpe:/a:novell:opensuse:openssh-debugsource, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/01/15

Reference Information

CVE: CVE-2016-0777, CVE-2016-0778