openSUSE Security Update : perl-Module-Signature (openSUSE-2016-61)

Critical Nessus Plugin ID 88133


The remote openSUSE host is missing a security update.


This update to perl-Module-Signature 0.79 fixes the following security issues :

- More protection of @INC from relative paths.

- Fix GPG signature parsing logic. (CVE-2015-3406)

- MANIFEST.SKIP is no longer consulted unless --skip is given. (CVE-2015-3407)

- Properly use open() modes to avoid injection attacks.


Update the affected perl-Module-Signature package.

See Also

Plugin Details

Severity: Critical

ID: 88133

File Name: openSUSE-2016-61.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2016/01/25

Modified: 2016/01/25

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl-Module-Signature, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2016/01/19

Reference Information

CVE: CVE-2015-3406, CVE-2015-3407, CVE-2015-3408, CVE-2015-3409