PowerDNS Authoritative Server 3.4.4 / 3.4.5 / 3.4.6 Process Packet Handling DoS

High Nessus Plugin ID 87947


The remote name server is affected by a denial of service vulnerability.


According to its self-reported version number, the version of the PowerDNS Authoritative Server listening on the remote host is version 3.4.4, 3.4.5, or 3.4.6. It is, therefore, affected by a denial of service vulnerability due to an assertion flaw that is triggered when handling malformed packets. An unauthenticated, remote attacker can exploit this vulnerability, via crafted query packets, to crash the server.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.
Also, Nessus has not checked for the presence of the patch.


Upgrade to PowerDNS Authoritative Server 3.4.7 or later.
Alternatively, apply the patch referenced in the vendor advisory.

See Also


Plugin Details

Severity: High

ID: 87947

File Name: powerdns_authoritative_3_4_7.nasl

Version: $Revision: 1.2 $

Type: remote

Family: DNS

Published: 2016/01/15

Modified: 2016/04/29

Dependencies: 34043

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:powerdns:powerdns, cpe:/a:powerdns:authoritative

Required KB Items: pdns/version_full, pdns/version_source, pdns/type, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/11/03

Vulnerability Publication Date: 2015/11/09

Reference Information

CVE: CVE-2015-5311

BID: 77522

OSVDB: 130016